Simulated Phishing Errors

Incident Report for Proofpoint Security Awareness

Resolved

This incident has been resolved
Posted May 05, 2025 - 03:17 EDT

Identified

We are currently investigating an issue with Simulated Phishing. Customers may be experiencing issues with Campaign management and sending of simulated phish.
Posted May 05, 2025 - 03:03 EDT
This incident affected: U.S. Environment (Simulated Phishing - U.S.) and Europe Environment (Simulated Phishing - Europe).